Zap Run Processing Delays

Incident Report for Zapier

Resolved

Issues/delays that rely on event-driven triggers, such as tasks and webhooks are resolved.

If you have any questions, reach out to our team here: https://zapier.com/app/get-help
Posted Aug 28, 2025 - 14:20 PDT

Monitoring

We’ve resolved an issue that was causing delays in how quickly events were being processed in our system. This impacted some workflows that rely on event-driven triggers, such as tasks and webhooks.

The root cause has been addressed, but there’s still a backlog of events waiting to be processed. It may take up to 3 hours for everything to catch up and for overall performance to return to normal.

During this time, you may continue to see delays in event-triggered actions. We’re actively monitoring the situation and will share updates if anything changes.

We’re sorry for the inconvenience and appreciate your patience while we work to fully restore service.
We appreciate your patience while we resolve the issue. Please reach out to our Support Team if you need anything: https://zapier.com/app/get-help
Posted Aug 28, 2025 - 09:39 PDT
This incident affected: Zaps (Instant Triggers, Polling Triggers, Searches & Writes).