The issue affecting some users—where they were incorrectly receiving alerts stating, "You've surpassed your subscription's task limit"—has been resolved.
If you continue to experience this issue or have any questions, please don’t hesitate to reach out to our Support Team: https://zapier.com/app/get-help.
Thank you for your patience and understanding as we worked to resolve this!
Posted Apr 16, 2025 - 09:52 PDT
Monitoring
We are currently monitoring a previously reported issue where some users were receiving email alerts informing them that they have exceeded their task limit. The specific notification stated, "You've surpassed your subscription's task limit."
We have now released a fix to address this issue and will continue to keep a close watch on the situation to ensure the complete resolution of the issue. We kindly ask users who encounter further issues or have any questions to reach out to our Support Team at https://zapier.com/app/get-help.
We appreciate your understanding and cooperation.
Posted Apr 15, 2025 - 14:52 PDT
Investigating
We are currently investigating an issue where users are receiving an error message indicating that they have surpassed their subscription's task limit, even though they have not. The specific error message being received is: "You've surpassed your subscription's task limit."
The issue appears to be affecting the email notifications sent to users. Despite the error message, please note that the task number showing in your Zapier account remains accurate.
At this time, we are not aware of any data loss related to this incident. We are currently working to resolve the issue and will update this status page as we have more information.
If you experience any further issues, please do not hesitate to reach out to our support team: https://zapier.com/app/get-help