Issues loading Zaps and folders

Incident Report for Zapier

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 09:30 PDT

Investigating

We're currently experiencing an issue where users may encounter difficulties loading Zaps and folders.

We'll be updating this page as we get further information. If you need help, please contact Support: https://zapier.com/app/get-help
Posted Aug 25, 2025 - 08:52 PDT