Upgrade Modal preventing Zaps from being published

Incident Report for Zapier

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 12:33 PDT

Monitoring

At this time, we do not currently believe Zapier customers are impacted by this issue.

We will continue to observe, and mark this as resolved once full scope is captured.
Posted Aug 19, 2025 - 12:29 PDT

Investigating

Some users may see a 'payment required' type popup modal when trying to publish a Zap, which is being incorrectly applied and is preventing the Zap being published.

We are currently investigating this issue, and will update this page as this progresses.
Posted Aug 19, 2025 - 11:12 PDT