Possible delays in polling triggers

Incident Report for Zapier

Resolved

We have resolved the issues related to increased latency across multiple services.
Posted Aug 21, 2025 - 13:03 PDT

Monitoring

We have a fix regarding the issue with increased latency across multiple services. Things are improving, and we are actively monitoring this issue.
Posted Aug 21, 2025 - 12:30 PDT

Investigating

We are currently investigating reports of delays in Zaps that use polling based triggers.

We are continuing to investigate, and update this page once more information is available.
Posted Aug 21, 2025 - 11:33 PDT
This incident affected: Zaps (Polling Triggers).