Issues with Task Processing and Slow Homepage Loading

Incident Report for Zapier

Resolved

Our team has resolved the issue encountered earlier which caused some delays and errors in task processing, as well as slow loading times on our logged-in homepage.

Thank you for your patience and understanding while our team addressed these issues!
Posted Apr 02, 2025 - 14:43 PDT

Identified

We have identified the root cause of the delays and errors in task processing, as well as the slow loading times on our logged-in homepage. Our team has temporarily scaled up the system resources, which has improved performance.
Posted Apr 02, 2025 - 11:50 PDT

Investigating

The problems started at 10:31 PST today. They are affecting:
Task Processing: Some tasks are delayed or not completing correctly, especially in areas of our service that handle a lot of data at once.
Homepage Loading: It’s taking longer than usual for the main parts of our website to appear after you log in.
Posted Apr 02, 2025 - 11:13 PDT